
Using Green Screen in ImageMatch 
 
This document will serve as an introduction the Green Screen Version 2 which is 
included as a part of the 2008 ImageMatch release.  This version has been optimized for 
green backgrounds.  Blue backgrounds are not supported. 
 
Getting Started: 
 
Proper lighting is key to getting good results from any green screen software.  You must 
do some testing to determine how it will work best for you.  Recommended light 
diagrams are available at the PhotoLynx Website.  Flat lighting, with no background light 
or hair light works best.  The background should be about 1 stop darker then your 
subject.  The background must be smooth and free of shadows.  All images within the 
job must be lit consistently. 
 
After you update your computer with the 2008/2009 ImageMatch release, you must go to 
File->Preferences->ImageMatch and select Green Screen V2.  
 
You will first need to either load green screen images (and their corresponding data) into 
ImageMatch or import a job from CamLynx that was photographed on a green screen. 
Then, Choose Green Screen from the Imaging Menu.   
 
Tip – If you select Ctrl-G and click on an image, the green screen window will open to that image 

 

Green Screen Window 

 
 



Begin by selecting the “Default Settings” button from the bottom right of the Green 
Screen window. This will set the green drop out values to the default optimum settings 
for most green backgrounds. 
 
Select the Background Definition Tool and select and area between the subject’s 
head and any edge of the frame. 
 
To drop the green background from all of the images, select the Apply Color to All 
Images button on the bottom right of the Green Screen Window. 
 
The strip of images across the top of the Green Screen window allows you to quickly edit 
images where subjects may be wearing green. Your images will appear across the top of 
the screen for easy proofing. For images that may need some work, just click on them to 
bring them down to the pallet. Go through all of your images to edit them as necessary.  
 
Tip – After applying the green screen settings to everyone, close the green screen window.  Tag 
everyone in the job with wearing green.  Filter on tagged images.  Now when you reopen the 
green screen window, only those wearing green will display across the top in the Green Screen 
Window 

 
Toolbox 
Tools are provided on the left side of the screen. The tools with an ‘X’ icon next to them 
means it will remove an area from your image. The tools with a ‘+’ icon next to them 
means it will add back an area to your image.  Most of the tools are used for bringing 
back areas of an image that may have dropped when the green was removed from the 
background. 
 
In the upper left portion of the screen, you may select the Show Crop box to show the 
crop applied in ImageMatch.  You do not have to make any adjustments to the grayed 
out area, as they will not be a part of the output for the selected crop.  If your image 
comes in looking grayed out, this means no crop was applied in ImageMatch.  Remove 
the check from the Show Crop Box. 
 
The Filter Delete and Filter Duplicates boxes, when selected will remove any images 
that were marked as deletes (red boxes) or duplicates (blue boxes) in the ImageMatch 
job.  This will save time by eliminating them from adjustments. 
 
The Background Definition Tool is used to drop define a background color that may 
not have dropped out completely using the Default Settings. 
 
The Move Tool will allow you to move the image on the pallet when it is magnified. 
 
The Background Color Picker tool allows you to select a color to remove(X) from an 
image. 
 
The Foreground Color Picker tool allows you to select a color to add(+) to the image.   
 
Tip – There is no ‘undo’ for the eye dropper. To get your colors back, you must select the default 
Settings button 
 

 
 



The Background Lasso tool allows you to lasso an area of an image to remove(X) an 
area from the image.  This tool would be used to remove an area of an image that has a 
fold or other object showing in the background. To undo the lasso, use Ctrl-Z. To redo a 
lasso, choose Ctrl-Y. 
 
The Foreground Lasso tool allows you to lasso an area of an image to add(+) an area 
to an image.  This tool would be used to add back green colored clothing in the image. 
To undo the lasso, use Ctrl-Z.  To redo a lasso, choose Ctrl-Y. 
 
Tip – Right click on either Lasso tool to choose from Free Hand to Polygonal Hand.  With Free 
hand, you must hold down the right mouse button continuously until you reconnect to the starting 
point.  With Polygonal Hand, you can select points to connect.  Select the first point to complete 
the shape and select the area. 

 
The Background Brush tool uses a circular shape to remove(X) an area from an 
image.  The Brush Type Size is shown on the right side of the screen when the tool is 
selected.  To undo a brush, use Ctrl-Z. To redo a brush, choose Ctrl-Y. 
 
The Foreground Brush tool uses a circular shape to add(+) an area from an image.  
The Brush Type Size is shown on the right side of the screen with the tool is selected.  
To undo a brush, use Ctrl-Z. To redo a brush, choose Ctrl-Y. 
 
Select the Zoom tool to enlarge the image. Left click will enlarge the image, right click 
will reduce the image back down to the original viewing size. 
 

Choosing a single background for all images 
To select a single background for all of you images, select the “Browse” button from the 
bottom right corner of the Green Screen Window. This will open up a browser to select a 
background for all of your images. Select the “Apply Background” button, then “Apply to 
all’ to set that background to all of your images. 

 
Choosing a background image with Package Orders 
You may use the Package Options to select different backgrounds based on a student’s 
package order.  The package Options must be set and an option assigned to each 
package, as explained below.  Select the “Apply Background” button, then “Auto assign’ 
to set that background to all of your images. 
 

Creating a Package Option 
1. Open ImageMatch and Restore a Job. 
2. Go to File > Preferences, select the Packages Tab 
3. Make sure to load the Package Units Definitions* File that will be used for 

printing in RipLynx. Select the Package Program to be used. Click OK. 
4. Press F7 while clicking a picture to open Package Selection. 
5. From the menu, Units > View Package Options. 
6. Units > Edit Options. Print Options window should be displayed 
7. Click the Add button. 
8. Click the Edit button. 
9. Enter the desired Map number. Example: SKY for a cloud background. 
10. Enter the Description of your Option. Example: Sky background. 
11. From the menu, Insert > Background Image. 
12. Click the […] button to select the background image. 
13. Click OK. 



14. Repeat steps 3 thru 13 to add more Background Options. 

 
Tip - The Package Options are saved to the PUD, so make sure you share this PUD with all 
computers using this function, and/or add it to the CD when sending the job to the lab for printing. 

 
 
Option Package Entry 

1. Open ImageMatch. 
2. Make sure you have a valid Package program and PUD loaded. 
3. Press F7 and click a picture to bring up Package Selection. 

4. Make sure your Package Options are visible. Units > View Package 
Options. 

5. Enter your packages using Barcode, Keyboard, or Mouse. 
6. Enter your Package Option by checking the Box next to the option or by 

using the Number keys 1-9. 
7. Remove the Package option by un-checking the Box or by using the 

Number keys 1-9. 

 
The Green Screen adjustment is applied at Output 
Backgrounds are replaced when ImageMatch sends the images to an export, to print 
packages in RipLynx, or when services are created with ProServices. The original image 
is never changed, the green background will remain. This allows you to choose different 
background images for services, packages and exports, or when a different package is 
ordered.  Your images will still have the green behind them in the main ImageMatch 
Screen. 
 
                 
                   ____________________________________________________ 
 
 
Further Suggestions: 
 

Setup Job for Green Screen 
Optimizing green drop out by camera: 

� Open Color Corrected job in ImageMatch 

� Tag the range of the first photographer (roll) 

� Filter on tag 

� Open Green Screen panel 

� Click on Default Settings 

� Click on Background Definition tool (Green silhouette) 

� Click on one spot between the head and the edge of the background 

� Apply Color to all backgrounds 

� Apply Background - Auto Assign 

� Close Green Screen Panel 

� Clear Tags 

 
 
 
 



 
Prepare White Shirts 
Sometimes white shirts have a green outline, here is the workflow to fix if it 
occurs.  This happens due to improper lighting. 

� Tag all subjects in the first photographer wearing solid white. 

� Filter on Tag 

� Enter Green Screen Panel 

� Magnify the image to clearly see the teal line along the edge of the white shirt. 

� Use the Green + Eye Dropper to select the teal line; you will see the color on the right 

hand side. 

� Apply Background to all 

� Clear Tags 

Repeat above steps for each photographer 

 
Green Screen Editing 

� Tag each subject with green. Be careful to look for small items, like hair ties and graphics 

within shirts. If you think that there image may be affected with a green drop out, select 

it to be on the safe side. 

� Filter on Tags 

� Start by using the Green + foreground brush at it's largest size 

� Paint over the areas where the green should be seen 

� To refine the edges (sleeves, collars, etc. use the Foreground + lasso) 

� Click on the green check mark in the upper right portion of the screen, the select ‘Apply 

to Current’. BE VERY CAREFUL NOT TO SELECT "Apply to all" as this will wreck the work 

you have done so far. 

 
Tips: 

� On Average 10 % of a job will have green somewhere within the subject. 

� 80% of the images with green in it can be fixed with the brush tool alone. Use different 

size brushes for sleeves and other areas. 

� Right click on the Foreground lasso tool to select Polygonal hand. This will allow you to 

select points around the edges to connect the dots. 

� Don't fix more the necessary. Most of the time, if the shirt has a design in it, the edges 

won't make a difference. 

� Ctrl-Z will remove all tools one step back in history at a time 

� Ctrl-Y will add back all tools one step forward at a time 

� Use many clicks. If you mess up and have to use Ctrl-Z, it won't step you back as far as if 

you held down the mouse button and did a continuous stroke. 

� Sometimes the edges will completely disappear into the background. Click on default 

settings to bring them back into view. Be sure to re-apply the background definition tool 

when saving that subject. 

� The higher the resolution your background, the better the quality of your finished 

prints.  But, the disadvantage to larger background images is a slow down in rendering. 

� It’s Important that pud in ImageMatch matches RipLynx 

� SAVE YOUR JOB OFTEN 

 
 
 
 



 

ADVANCED GREEN SCREEN TECHNIQUES  

 
There may be cases where you may want to apply more then one background for an order, proof, 

or package unit.  ImageMatch only supports one background per subject.  Here are some tricks to 

create these items. 

 

More Than One Background in an Order 
1. File->Preferences->ImageMatch->Select “Duplicate Image on “Copy Image” 

 
2. Go to the record that has the order for multiple backgrounds. 

3. Click on the blue bar below the record 

a. Choose Copy Image 

b. Choose Copy Record 

4. Enter your package and your background as you normally would, with a different 

background selected for the other record(s). 

 
 

Tip – To undo Copy Image, Copy Record, Select the blue bar below the image on the left.  Choose 

Undo Copy Image, then Choose Delete.  Copied Images will appear twice in your reports, composites, 

and any other service you produce.  After the packages are printed, you can blue box (hold down F2 

Key and click on one of the images) to keep it from being output with your services. 

 

 

 



Green Screen in ProServices 

 
Green Screen Limitations:  

• ProServices does not support frames or masks in the template while using Green Screen. 

• ProServices does not support the drop out of a transparency color while using Green 

Screen. 

 

To workaround the lack of support for transparency through ProServices in green screen, we 

suggest converting any graphics that currently contain a drop out color to a .png file.  Replace the 

drop out color with a transparent (alpha channel).  Although the transparent channel does not 

display correctly in the template builder or preview in ProServices, it will render correctly in 

RipLynx.  Currently there is no workaround for frames or masks. 

 
Tip – Until the transparent (alpha channel) is supported in the template builder, use the original image 

with the drop out color as you normally would to align your template.  Once everything is aligned 

correctly, replace that image with the .png file in the template builder. 

 

With the exception of the above limitations, ProServices will work as normal. 

 

Multiple Backgrounds on a Proof through ProServices & RipLynx 

 

 
 

This outlines the steps involved to create a proof as shown above, with 1 image on 3 different 

backgrounds.  These instructions assume you have experience with ProServices & RipLynx.  The 

large majority of the steps involved are in the setup. 

 

Setting up your Service 

1. Open ProServices 

2. As a starting point, Select ‘pl_proof’ for your service 

3. Goto the Template Builder – Templates->Edit Template->Proof Sheet.tem 

4. Add an ImageObject – Edit->Add Object->Image 

5. In the Image Tools box, select your first Image, LEAVE THE DATA FIELD BLANK 

6. Place the image over the top of the first position on your proof sheet 

7. Duplicate the Object – Edit->Duplicate Object.  Assign the object a new name 

8. Move the New Image Object over the second position in the proof 

9. In the Image Tools box, change the background to your next image 

10. Repeat Steps 7-9 until all of your backgrounds are placed 



 
11. One at a time, send all image objects that will be used for backgrounds to the back layer.  

Do this by choosing the icon at the top of the screen that has the Yellow box behind the 

two dark boxes. 

12. The ‘Place Holder’ Image used for your subject’s image should now be displayed as the 

top layer.  One by one, change the Data Field in the Image Tools for the subject’s image 

to ‘ImageName’. 

 

Setting Up Your PUD 

1. In ImageMatch->File Preferences->Packages->Config button for the pud 

 

 



2. Add a unit 

3. Change  your unit type to Service 

4. Give your unit a Description & Short Description 

5. Under Service Setup select the three dots to select the service created for your green 

screen proof sheet. 

6. Save your pud 

 

Setting Up Your PRM 

1. In ImageMatch->File Preferences->Packages->Config button for the prm 

 
2. File->New to start with a new prm file 

3. Add a description 

4. Click on Add to add a package 

5. Enter the package Description, Title, and Map # 

6. Choose ‘Add Unit’ 

7. Select the Green Screen Unit from the pud 

8. Save your .prm 

 

Create a Transparent Background 
1. In PhotoShop, Create an 8x10 transparent (alpha channel) image and save it as a .png. or 

download it from the PhotoLynx web site.  Save the file to your backgrounds directory. 

 

Your set up is complete.  To print proofs follow these directions for each job. 

 

Add Packages to Your Job 

1. Load the green Screen ImageMatch job you wish to create proofs from into ImageMatch 

2. Ctrl-J to go to the Search and Replace Data screeb 

3. Change Source Field to Packages; Change Destination Field to Packages 

4. Enter in your map number for the package and a -1 for the quantity (Using the example 

above, the map number is GSP, so you would enter GSP-1) 

 

 



Applying a Transparent Background 

1. Imaging->Green Screen  

2. Browse and select the Transparent.png file 

3. Apply Background->Apply to All 

 

Send to RipLynx 

1. Open RipLynx 

2. Verify that the pud in ImageMatch matches the path to the pud in RipLynx 

3. Print Job from ImageMatch to RipLynx 

 

Tip – This method can be combined with the multiple pose or multiple crop methods to allow for 

more then 1 pose to be displayed in your proof.  

 

Multiple Backgrounds on a Unit 

 
 

This outlines the steps involved to output a single image with multiple backgrounds on a unit 

through RipLynx.  The background is controlled through the unit.  There is no way to do multiple 

backgrounds by providing choices through Options.  The same background will always be used 

for the unit as designed.  If options are applied to the image, the backgrounds with the subunits 

will be replaced completely by the background selected in the option.  These instructions assume 

you know how to create a unit in the pud and know how to work ProServices. 

 

Create a Transparent Background 

1. In PhotoShop, Create an 8x10 transparent (alpha channel) image and save it as a .png. or 

download it from the PhotoLynx web site.  Save the file to your backgrounds directory. 

 

 

 

 



 

Add Background to the Unit 

1. File->Preferences->Packages->Config button for the Package Units Definition 

2. Create a new unit with sub units as needed 

3. Click on the word ‘Preview’ from the file menu.  Be sure that the ‘Full Preview’ is turned 

off. 

4. Click on the subunit for the first background to be applied 

5. Place a check next to Sub-Unit Graphic (Not Unit Graphic) 

 
6. Click Edit Graphics 

a. Insert->Background Image 

b. Apply to: This Sub Unit 

c. Image->Browse to the background image needed for this sub unit 

7. Repeat Setps 4-6c for each sub unit. 

 

Add Unit(s) to your prm file 

1. In ImageMatch->File Preferences->Packages->Config button for the prm 

2. File->New to start with a new prm file (skip this step to add to an existing prm) 

3. Add a description 

4. Click on Add to add a package 

5. Enter the package Description, Title, and Map # 

6. Choose ‘Add Unit’ 

7. Select the Green Screen Unit from the pud 

8. Save your .prm 

 

Applying a Transparent Background 

1. Load a Green Screen ImageMatch job 

2. Imaging->Green Screen  

3. Browse and select the Transparent.png file 

4. Apply Background->Apply to All 

 

Send to RipLynx 

1. Open RipLynx 

2. Verify that the pud in ImageMatch matches the path to the pud in RipLynx 

3. Print Job from ImageMatch to RipLynx 


